Unable to start game from homepage

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Unable to start game from homepage

      Hi,

      I bought an verrified account from OBTGames and use thei VPN offer as well.

      I was able to login and download the game.
      Game installed fine as well.

      However when I try to start the game with either IE, Chrome or Firefox this pops up:



      It says something about having to set up the system so the game can start directly. i don't get it.
      It also tells me I can install PstallSetup.exe manually.

      I click it and Windows UAC asks me if I want to install it, I click yes and then nothing seems to happen.

      After some time this pops up:



      I can't translate that. No idea what it says.

      What am i doing wrong?
    • Message says: Install the Pmang Launcher Failed.

      If you want to install it manually just download it by clicking on the red framed button.

      The Pmang Launcher connects the Web GameStart with the Client Start Up so you 100% need it.

      It takes some time to install it but if installed successfully it gives a message.

      If you already installed it, you likely need to restart the browser.

      If you didn't install it, you need to do so.

      I also use chrome however IE works best

      Btw. Willkommen im Forum =)
    • It says "We have completed the necessary settings for the game. Please start the game again, using the start button".

      So just refresh your browser session (F5) and press game start again (I think). Other users also had this problem or this message coming up.
    • Someone remember the time when you could start a client enter a Username and PW and be done?

      Anyway I tried IE again. Seems I was able to get a little further.
      I switched off UAC and paused my Anti Virus software.

      I pressed start and then this page loads:



      Apparently it says the game is now running... except it isn't.

      After some time I get this nonsense:



      let me guess: The game is missing this PIS.dll?

      Edit: BTW. I can run this game from the directory.
    • missing PIS.dll comes from the fact the pmang launcher can't connect to the servers.

      I switched my VPN off and it worked.

      You can switch off your vpn while downloading but it can be stuck and if it patches successfully gameguard will prevent you from starting the game. So you would have to start the game again from the website.
    • I'm getting as far as the splash screen, but after a while, the splash screen closes and any/all of my minimized windows pop back up. I've tried waiting it out for a few minutes and nothing launches, and I don't appear to have any background processes going on for Bless...

      Using the PCVPN... Anyone know of a good solution?
    • Foreen wrote:

      Don wrote:

      Sorry for the double post. Just figured I'd lend a hand to the translating business--

      Foreen - Your error says you're not playing from South Korea. You need to use a VPN.


      Can you tell me what VPN works best, and what settings I need for the VPN?

      A lot of people here are using PCVPN it looks like. WTFast might work as well.
    • So, for my issue (where I get as far as the splash screen, then nothing), I tried a fresh reinstall and kept the VPN up the whole tile this time around (which as far as patching goes was significantly slower, so I left it going over night). Didn't appear to solve the issue.

      Anyone know what's going on? After the splash screen I get nothing. No background bless.exe process running, no nothin'. I made sure all of my drivers were up to date (and uninstalled and reinstalled one just to be sure). I have no anti-virus programs or firewalls running anywhere, and I tried launching from IE. UAC is not active. Any help would be appreciated.
    • I got the same issues and still the same things :/

      I tried to launch the game from Binaries\Win64, it works but not from the website, I downloaded the exe 24 times and still the same issue as Ishigami in his first post

      Edit : problem solved by switching off my UAC

      The post was edited 2 times, last by Exdeath03 ().

    Peria Chronicles